The site is still under construction, some functions may not be available.
HomeDocumentationsServer Requirements

Last Modified: June 11, 2020

To use Glekk, you must be running WordPress 4.7 or higher, PHP 7.0 or higher (WordPress officially suggests to use PHP 7.4, read more) and MYSQL 5+.

Before you proceed to install the theme, make sure that comply all of the points below:

  • Ensure your web host has the minimum requirements to run WordPress.
  • Make sure your WordPress version (4.7+) is installed and working. If necessary, you can download the latest release of WordPress from the official WordPress website.
  • HTTPS support

Note

If you use a hosting service with limited resources (e.g. GoDaddy!), you may experience issues with the demo data installation. We are not responsible for problems associated with third-party services.

PHP Configuration limits

PHP has several configuration options to limit resources consumed by scripts. By default, PHP is set to allow uploads of files with a size of 2MB or less. Increasing the following values in php.ini:

  • memory_limit – 256M
  • max_input_vars – 3000
  • max_execution_time – 120
  • post_max_size – 128M
  • upload_max_filesize – 128M

Setting these values will ensure you will not get error messages during the installation. To safeguard your website, please use secure passwords and the latest version of WordPress and plug-ins.

Verify your PHP limits

You can check PHP configuration settings from Dashboard > Tools > Site Health > Info > Server. For more detailed information you can use following plugins:

Also, you can always contact your host to ask what the current settings are, and have them adjusted if necessary.